spacer
cornerspacercorner
Reply
Occasional Contributor
Craig Wright
Posts: 3
Registered: ‎05-25-2010
0 Kudos

V9 Open folder error

Hi,

 

I have an odd problem which I haven't been able to narrow down while opening folders in V9 via an external application, any help or work-a-rounds greatly appreciated! 

 

We are using V9 SR2 Hotfix 2 with SSO enabled on Windows Server 2008, MS SQL Server 2008.The application is desktop based and launches an IE8 window as a popup using this Url format:

 

http://<Server>/Metastorm/eFolder.aspx?FolderID=<FolderId>&Client=External

 

When an IE instance has already been opened and holds an active session everything is fine, if the app launches a new instance of IE however on occasion (more often than not, not always on opening but sometimes on switching folder tabs) we receive the following error:

 

Failed to execute 'start action'. Method 'SqlServerDatabaseConnector.UpdateAction', parameter 'actionName' is null or empty.

 

This is becoming a major annoyance to users and will only get worse as we roll out more M9 processes in the near future. I have found a similar error described on the forum for the Office integration tools but it only lists it as a known error with no ETA on fix.

 

Cheers,

Craig

Occasional Advisor
Mark Gregorio
Posts: 6
Registered: ‎05-19-2010
0 Kudos

Re: V9 Open folder error

We are also having the same issue. Has anyone come up with a solution for this issue?

Esteemed Contributor
Jerome҉
Posts: 914
Registered: ‎05-18-2010
0 Kudos

Re: V9 Open folder error

We have found that there seem to be two URLs needed for SSO. I documented it here somewhere, but was told that only one was needed (which is not the case).

 

As you see, one workes when IE is not open, but there is another that works when IE is already open, or at least if you are logged in to Metastorm. We have no resolution as the problem is not recognised.

Occasional Advisor
Mark Gregorio
Posts: 6
Registered: ‎05-19-2010
0 Kudos

Re: V9 Open folder error

I believe we have determined the issue. The URL to open a blank form per Metastorm Web Client Configuration Guide is http://<Web Server>/<Web Client Virtual Directory>/eForm.aspx?Map=<Metastorm Map Name>&Client=External[&Action=<action Name>. This doesn’t work correctly. The correct URL is http://<Web Server>/<Web Client Virtual Directory>/eForm.aspx?Map=<Metastorm Map Name>&Action=<Action Name>I&Service=Metastorm%20BPM%20Server.

jcm Employee
Employee
jcm
Posts: 251
Registered: ‎05-25-2010
0 Kudos

Re: V9 Open folder error

I tried the documented URL with no service parameter with IE 8 closed and IE 8 open against a system using SSO and it seemed to work fine for me. Could there be some other detail which is causing problems on these systems?

line spacer line
spacerFollow Metastorm on:
spacer Twitter YouTube Blog iTunes LinkedIn Metastorm Community Central, MC2
spacer Copyright © 2011 OpenText Corporation. All Rights Reserved.spacer About Metastormspacer Privacyspacer Legalspacer Site Mapspacer RSSspacer Contact Us
Microsoft Gold Certified Partner
Powered by Windows Azure
line spacer line